
There are several ways to create a new presentation using Google Slides. Some examples within this 

lesson: 

● Create a new presentation from Google Drive 

● Upload an existing Microsoft PowerPoint® file and convert it to a Slides file 

● Use the templates gallery to start with a designed layout 

Create a new presentation from Google 

Drive 

To create a new presentation from Google Drive, go to your Documents List, click the New button, and 

select Google Slides from the drop-down menu. 

 

There is no Save button in Google Slides. As soon as you name the document or start typing, your work 

will be automatically saved every few seconds. 

Slides presentations that you create will be listed in the Google Drive Documents List, on 

slides.google.com (or google.com/slides), and searchable on both sites. 

You can download a copy of your presentations to your Mac, PC, tablet, or mobile device. In the Google 

Drive Documents list, right-click on your presentation, select Download, and the presentation will be 

saved to your computer as a Microsoft PowerPoint® file. Or, open your presentation, open the File menu 

and select the Download as option. Select a format from the list including images (.png, .jpeg, .svg), 

portable document format (.pdf), text (.txt) or Microsoft Powerpoint® (.pptx). 

Upload a presentation from your computer 

https://docs.google.com/templates?type=presentations
http://drive.google.com/


You can upload existing presentations to Google Drive. When you are uploading, you can either keep 

your document in its original file format or convert it to Google Slide format. 

You can upload and convert from the following file types: 

● Microsoft Office PowerPoint® 1997-2003: .ppt 

● Microsoft Office PowerPoint® 2007-2013: .pptx 

● Microsoft PowerPoint Show®: .pps 

To upload a presentation file and convert it to a Google Slides document: 

1. Review Settings to make sure that Convert uploaded files to Google Docs editor format 

is checked. 

2. Click the New icon in the top left of your Documents List. 

3. Click File upload and select the presentation you would like to upload. 

4.  

5. Click Open. 

6. The file will upload and appear shortly in your Documents List. 

Note: Files not converted to Google Docs editor formats use space from your Google Drive storage. For 

more information on document file limits, check out the Support Center. 

Use the Template Gallery 

The Google Docs Template Gallery has presentation templates that you can use as a starting point for 

designing your slides. Each template has standard text that you can replace with your own and preset 

styles that you can reuse. 

Templates can be an easy way for students to get started with presentations as they can focus on content 

instead of design. Some of the presentation templates are like themes with slides empty of written 

content, but filled with a custom design. Other templates have content ideas or outlines such as a how-to 

picture creation slideshow or create a certificate. 

For example, for a monthly faculty meeting, you could create a standard presentation that follows the 

meeting agenda. Students can use a template to get started quickly for “show and tell” and customize the 

presentation with their own unique information. 

In addition, presentation templates can be used to standardize class presentations for projects. 

Templates can include instructional information as well as placeholders, but those who use the template 

still have the ability to customize it with themes, objects and content. 

https://support.google.com/drive/answer/6558?hl=en
https://support.google.com/drive/answer/37603?hl=en
https://drive.google.com/templates?view=public


To learn more about creating and using templates, check out more in the Support Center. 

Insert a slide into a presentation 

There are four ways to insert a new, blank slide into your presentation. 

● Click the New slide button directly above the list of slides on the left.  

● Go to the Slide menu and select New slide. 

● Right-click in the slide filmstrip and select New slide. 

● Use the Ctrl+M keyboard shortcut. 

By default, the new slide will have a Title and Body layout. To change this layout or apply a theme, go to 

the Slide menu, and select Change Layout or Change Theme. 

Slide layout 

When you create a new slide, you have roughly six different options for a slide layout. 

 

https://support.google.com/drive/topic/1360899?hl=en&ref_topic=2799627


Note: You can always customize the layout of your slide by inserting images, drawings, text boxes, 

tables, and more. If you plan to use a more custom format, you may want to select the Blank slide 

template. 

Add text or objects to a slide 

In Google Slides, you can draw lines, shapes and other objects directly on a slide in your presentation. 

Select a drawing tool from the Insert menu or from the toolbar to insert into the current slide. 

To edit text or an object, click the shape. Choose the formatting option from the displayed toolbar such as 

line weight, line dash, and arrowheads. Check out the Support Center to learn more information about 

text and objects on a slide. 

Arrange objects on a slide 

To change the way objects are arranged on a slide: 

1. Select an object or multiple objects. 

2. Click on the Arrange menu and choose from the following options: 

○ Order: Move your objects to the back or forward depending on how you want 

to overlap your text and objects 

○ Align: Align objects horizontally, vertically, or center them on a page 

○ Rotate: Use the rotate menu to flip your object(s) horizontally and vertically 

○ Group or Ungroup: Group objects to easier to format or move on the slide 

3.  

Note: Every option in the Arrange menu is also available when right-clicking on an object. 

https://support.google.com/docs/answer/2698842?hl=en
https://support.google.com/docs/bin/answer.py?answer=1696586


Insert an image or video into a slide 

Adding images and videos to your presentation or your students’ presentations can add flair and 

interactivity. Visuals can create deeper engagement during the presentation delivery in the classroom. 

Images 

Images can sometimes make your message stand out more than text alone. Here are six ways to insert 

an image into your presentation: 

● Drag-and-drop an image from your computer directly into a slide 

● Drag an image from the web directly into your presentation 

● Upload an image that is saved to your computer; enter the URL of a publicly available 

image from the Internet 

● Take a picture with your webcam and insert it directly into the presentation 

● Find an image through Google Image Search 

● Choose an image that is in one of your Picasa Web Albums or Google Drive 

● Browse Stock photos and select an image 

Note: Before using an image from the Internet, make sure that you have the rights to use that image. 

There are many sites on the Internet that offer images under a Creative Commons licenses, which may 

be appropriate for your use. See Creative Commons Search for more details. 

Inserted images must be in .png, .jpeg or .gif (no animated gifs though) file formats. Images can have a 

maximum of 2500 pixels in dimension and a maximum of 5 megabytes (MB) in size. 

To insert an image in your presentation: 

1. Go to the Insert menu, and select Image. Alternatively, click the Insert image icon in the 

toolbar, to the right of the T text icon. 

2.  

3. Choose one of the options available to insert an image, and choose a file, enter a URL, or 

do a search. 

4. Once you have selected an image, click Upload or Select. 

5. The image will be inserted into the selected slide. 

To move the image to another place on the slide, just drag-and-drop it. To resize the image, use the white 

resize handles surrounding the image. 

Insert Word Art into a slide 

Word Art lets you add different formats to text and headings in a slide. 

To insert Word Art into a slide: 

1. Go to the Insert menu and select Word Art. 

http://search.creativecommons.org/


2. You will be prompted to enter text to display. Type in the text, using Shift+Enter keys to 

include multiple lines of text. 

3. Press the Enter key to save. 

You can format your word art by selecting the text box and modifying the font, text size, and color options 

in the toolbar. Right-click the Word Art to change the properties. 

Snap to grid 

Snap to grid allows you to easily auto-align text, images, shapes, and tables. In the new and old versions 

of Slides, Snap to guides is enabled by default. For the new version, you can enable or disable the Snap 

to grid and Snap to guides options under the View menu. 

Edit a table in Google Slides 

To add rows and columns: 

1. Click inside the table to select a cell or row. 

2. Click Table menu and select from the following options: 

○ Insert row above the selected cell/row 

○ Insert row below the selected cell/row 

○ Insert column to the right of the selected cell/column 

○ Insert column to the left of the selected cell/column 

3.  

4. Right-click a cell or cell range to access the menu to insert or delete rows and columns. 



5. Add rows to the table by selecting the cell in the bottom right corner and pressing the Tab 

key. 

Format, resize, or move objects on a slide 

Google Slides gives you many ways to format text and objects on a slide. To get started, click the object 

you want to format, resize, or move. 

● To add custom formatting to text or an object, you can use the Format menu or the toolbar 

above the slide editing space 

●  

● To resize an object, click one of the resize handles surrounding it; drag the box inward or 

outward to change its size. Preserve the object’s height or width by holding Shift while 

resizing the object 

●  

● To move an object, drag-and-drop it to another place on the slide 

● To turn on vertical and horizontal dragging guides, hold the Shift key while dragging an 

object 

● To “nudge” an object in one pixel increments, hold the Shift key while moving an object with 

the arrow keys 

● To preserve an object's aspect ratio while resizing, hold the Shift key while resizing an 

object 

● To rotate an object 15 degrees at a time, hold the Shift key, click the small circle above an 

object, and drag your mouse clockwise or counter-clockwise 

Modify multiple objects at once 

To select multiple objects, hold the Shift key while selecting each object or drag your mouse over all of 

the objects you would like to select. To deselect one or more objects, press the Shift key and click the 

object(s). You can perform the following actions on all selected objects: 

● Move the objects with your mouse or the arrow keys 

● Resize or arrange objects 

● Copy and paste 

● Delete 

https://support.google.com/docs/bin/answer.py?answer=69084
https://support.google.com/docs/bin/answer.py?answer=69084


Copy and paste slides 

Copying and pasting slides is slightly different from duplicating slides because you can choose exactly 

where to insert the copied slide. With duplicating slides, the new slides appears directly after the original. 

You can also copy and paste slides from one presentation to another. 

Note: When you copy and paste slides into a different presentation, the newly pasted slides will adopt the 

theme of the destination presentation. Some of your designs and colors may change because of varying 

themes. 

To copy and paste a slide in your presentation: 

1. From the slide sorter (left-hand side thumbnail view of slides), select the slide you would like 

to copy. You can press Shift to select a sequence of slides, or press Ctrl to select multiple, 

non-sequential slides. 

2. Use the keyboard shortcut Ctrl + C (Cmd + C on a Mac) to copy the selected slide(s). 

3. Use the keyboard shortcut Ctrl + V (Cmd + V on a Mac) to paste the selected slide(s) within 

the presentation. 

Duplicate a slide 

1. Click on the Slide menu > Duplicate slide. 

2. Alternatively, from the slide sorter, right-click the slide you want to duplicate, and select 

Duplicate slide. 

3. To duplicate multiple slides, hold the Shift key and select the slides you would like to 

duplicate. Then, right-click the selection and select Duplicate slide. 

Delete a slide 

Choose one of the following options to delete a slide: 

1. Go to the Slide menu and select Delete slide. 

2. From the slide sorter, right-click the slide you would like to delete and select Delete slide, or 

just press the Delete key. 

If you accidentally delete a slide, or later decide you want undo deleting a slide, you can recover it using 

the undo button, or by reverting to a previous version by checking the Revision History. Learn more about 

Revision History from our Support Center. 

Organize slides 

https://support.google.com/docs/answer/190843?hl=en


As you or your students are working on a presentation, you may realize that the order of your slides need 

to be rearranged for better clarity. In Google Slides, you can easily reorder slides after you have created 

them. To start, select the slide you would like to move. Then, press the Shift key to select a sequence of 

slides, or use the Ctrl key to select multiple, non-sequential slides. 

To move your selected slide(s) to a different location, choose from the following: 

● Drag-and-drop the slide(s) to a new position in the list of slides on the left 

● Go to the Slide menu or right-click the slide(s), and select from the following options: 

○ Move slide up 

○ Move slide down 

○ Move slide to beginning 

○ Move slide to end 

Import slides from another presentation 

Importing slides is an easy way to reuse slides from an existing presentation. 

To import slides: 

1. Go to the File menu and select Import slides. 

2. Select a presentation that is already saved in Google Drive or choose a presentation to 

upload from your computer; click Select. 

3. Choose which slides in the presentation you would like to import; use the Select Slides: All 

option to quickly select all slides, or manually select slides that you would like to import. 

4. Leave the box next to Keep original theme checked if you would like to import your slides 

unmodified; uncheck the box if you would like the slides to fit into the look of your new 

presentation. 

5. Click Import slides to finish. 



6.  

If you receive an error message while importing a file into Google Slides, it could be for one of the 

following reasons: 

● The file is over the maximum import size of 50 megabytes (MB) 

● The file is not one of the Google Slides supported file types; Google Slides supports 

Microsoft PowerPoint® formats (.ppt, .pps, and .pptx) format 

To combine presentations from multiple creators (for example, students have worked separately on a 

topic and you want to combine their work into one presentation) you can create a master presentation by 

importing slides from each of the individual presentations. 

Import slides from one presentation to 

another 

1. Make sure that the presentation you wish to import has been shared with you. 

2. Select the slide in the slide sorter where you want to begin your import. 

3. Go to the Insert menu and select Import slides. 



4. Select the name of the presentation from the list. 

5. Using the slide sorter view, you can select slides one at a time or select all by clicking the 

Select Slides: All link beneath the first slide. 

6. When you have selected the slides you need, click the Import slides button. 

7. The slides will be imported beneath the slide you selected in step one. 

With your browser window set up ahead of time, you can quickly navigate to the correct tab and click the 

Present button for each new presentation. 

Note: When you create a master presentation with a theme, even a blank theme, any imported slides will 

adapt to that theme. If the other presentations were designed with a particular theme, those color and 

formatting choices will not be imported. 

To learn how to create and edit a master presentation and layout, check out more in the Support Center. 

Insert, format, and edit tables 

Insert a table 

1. Select a slide. 

2. Click Table, and select Insert table. 

3. Select the dimensions for your table. 

4. Once your table appears on your slide, you can start editing it. 

Format a table 

To change the background color of a table or a cell range within a table, select a range of cells. Then, 

click the Fill color icon (paint bucket icon), and select a color. You can also change cell border color and 

thickness for the entire table, a cell range within the table, or an individual cell. 

Edit a table 

To change color and thickness: 

1. Select the cell or cell range that you would like to edit. 

2. Click on the blue triangle in the upper right of the cell or cell range. 

3. Choose one of the nine options to format the borders from the drop-down menu. 

4. After you select an option, the selected cell borders will be highlighted. Then, format the cell 

borders using the Line weight, Line dash or Line decorations options under the Format 

menu. 

 

Resize a table 

To resize a table, point your mouse to any of the four corners of the table. When the mouse pointer 

becomes an arrow, you can resize by dragging inward or outward. 

https://support.google.com/docs/answer/3447671?hl=en
https://support.google.com/docs/answer/3447671?hl=en


To resize an individual row or column: 

1. Insert a table into the slide. 

2. Point your mouse to any of the inner borders of a cell. The mouse pointer becomes a two-

sided arrow. 

3. Drag the arrow to resize a column or row. 

Merge table cells 

1. Highlight the cells you would like to merge. 

2. Go to the Table menu and select Merge cells. 

3. To unmerge cells, highlight the cell and select Unmerge cells from the Table menu. 

For additional arrangement options like centering the table within the slide, right-click the table for a menu 

with additional options. 

Add videos from YouTube into a 

presentation 

1. Go to the Insert menu and select Video. 

2. Search for a video you would like to insert or enter a web address (URL) from YouTube. 

3. After you have selected a video, check the box next to the video's thumbnail and click Insert 

Video. 

4. The video will appear in your presentation. Once you have started playing a video, you can 

maximize it to the full size of a slide by clicking the full screen icon at the bottom right of the 

video. 

You can resize, move, and arrange the video much as you would any other slide object. 

 


